<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <link rel="profile" href="http://gmpg.org/xfn/11">
  <link rel="pingback" href="http://www.uafsunstar.com/xmlrpc.php">

  <title>Letters from the Editor: Flesh and blood &#8211; The Sun Star</title>

	  <script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Sun Star &raquo; Feed" href="http://www.uafsunstar.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Sun Star &raquo; Comments Feed" href="http://www.uafsunstar.com/comments/feed/" />
<link href="//fonts.googleapis.com/css?family=Source+Sans+Pro:400,300italic,300,400italic,600&subset=latin,latin-ext" rel="stylesheet" type="text/css">
<link rel="alternate" type="application/rss+xml" title="The Sun Star &raquo; Letters from the Editor: Flesh and blood Comments Feed" href="http://www.uafsunstar.com/letters-from-the-editor-flesh-and-blood/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.uafsunstar.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.1"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='akp-dynamic-css-css'  href='http://www.uafsunstar.com/wp-admin/admin-ajax.php?action=akp_dynamic_css&#038;ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='chosen-css'  href='http://www.uafsunstar.com/wp-content/plugins/classifieds-wp/assets/css/chosen.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-classified-manager-frontend-css'  href='http://www.uafsunstar.com/wp-content/plugins/classifieds-wp/assets/css/frontend.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='tt-easy-google-fonts-css'  href='http://fonts.googleapis.com/css?family=Libre+Baskerville%3Aregular&#038;subset=latin%2Call&#038;ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-lightbox-2.min.css-css'  href='http://www.uafsunstar.com/wp-content/plugins/wp-lightbox-2/styles/lightbox.min.css?ver=1.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css'  href='http://www.uafsunstar.com/wp-content/themes/hueman/assets/front/css/main.min.css?ver=3.2.10' type='text/css' media='all' />
<link rel='stylesheet' id='theme-stylesheet-css'  href='http://www.uafsunstar.com/wp-content/themes/hueman/style.css?ver=3.2.10' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css'  href='http://www.uafsunstar.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?ver=3.2.10' type='text/css' media='all' />
<link rel='stylesheet' id='wpgform-css-css'  href='http://www.uafsunstar.com/wp-content/plugins/wpgform/css/wpgform.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-frontend-style-css'  href='http://www.uafsunstar.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=3.7.1' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='http://www.uafsunstar.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css?ver=3.7.1' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='http://www.uafsunstar.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css?ver=3.7.1' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.uafsunstar.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.3.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.uafsunstar.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.uafsunstar.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.uafsunstar.com/wp-content/plugins/adkingpro/js/jquery.jshowoff.js?ver=4.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var AkpAjax = {"ajaxurl":"http:\/\/www.uafsunstar.com\/wp-admin\/admin-ajax.php","ajaxnonce":"3d42db300e"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.uafsunstar.com/wp-content/plugins/adkingpro/js/adkingpro-functions.js?ver=4.6.1'></script>
<link rel='https://api.w.org/' href='http://www.uafsunstar.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.uafsunstar.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.uafsunstar.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Op-Ed: The tragic flaw of the Democratic party' href='http://www.uafsunstar.com/op-ed-the-tragic-flaw-of-the-democratic-party/' />
<meta name="generator" content="WordPress 4.6.1" />
<link rel='shortlink' href='http://www.uafsunstar.com/?p=43953' />
<link rel="alternate" type="application/json+oembed" href="http://www.uafsunstar.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.uafsunstar.com%2Fletters-from-the-editor-flesh-and-blood%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.uafsunstar.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.uafsunstar.com%2Fletters-from-the-editor-flesh-and-blood%2F&#038;format=xml" />
            <style type="text/css">
                .adkingprobanner.rollover {position: relative;}
                .adkingprobanner.rollover .akp_rollover_image {
                    position: absolute;
                    top: 0;
                    left: 0;
                    z-index: 1;
                }
                .adkingprobanner.rollover .akp_rollover_image.over {z-index: 0;}
                .adkingprobanner.rollover:hover .akp_rollover_image.over {z-index: 2;}
                /* Add any CSS you would like to modify your banner ads here */            </style>
            <link rel="shortcut icon" href="http://www.uafsunstar.com/wp-content/uploads/2016/01/favicon.png" />
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]>
<script src="http://www.uafsunstar.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script>
<script src="http://www.uafsunstar.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script>
<![endif]-->
<link rel="canonical" href="http://www.uafsunstar.com/letters-from-the-editor-flesh-and-blood/" />

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Letters from the Editor: Flesh and blood" />
<meta property="og:url" content="http://www.uafsunstar.com/letters-from-the-editor-flesh-and-blood/" />
<meta property="og:description" content="Thanksgiving is not a universally positive holiday for many. Indeed, in some households it&#8217;s viewed with dread, representing an awkward, obligatory time of year where political views and fami…" />
<meta property="article:published_time" content="2016-11-22T19:00:00+00:00" />
<meta property="article:modified_time" content="2016-11-21T20:53:46+00:00" />
<meta property="og:site_name" content="The Sun Star" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
<style type="text/css">
/* Dynamic CSS: For no styles in head, copy and put the css below in your child theme's style.css, disable dynamic styles */
body { font-family: "Source Sans Pro", Arial, sans-serif; }

::selection { background-color: #213f99; }
::-moz-selection { background-color: #213f99; }

a,
.themeform label .required,
#flexslider-featured .flex-direction-nav .flex-next:hover,
#flexslider-featured .flex-direction-nav .flex-prev:hover,
.post-hover:hover .post-title a,
.post-title a:hover,
.s1 .post-nav li a:hover i,
.content .post-nav li a:hover i,
.post-related a:hover,
.s1 .widget_rss ul li a,
#footer .widget_rss ul li a,
.s1 .widget_calendar a,
#footer .widget_calendar a,
.s1 .alx-tab .tab-item-category a,
.s1 .alx-posts .post-item-category a,
.s1 .alx-tab li:hover .tab-item-title a,
.s1 .alx-tab li:hover .tab-item-comment a,
.s1 .alx-posts li:hover .post-item-title a,
#footer .alx-tab .tab-item-category a,
#footer .alx-posts .post-item-category a,
#footer .alx-tab li:hover .tab-item-title a,
#footer .alx-tab li:hover .tab-item-comment a,
#footer .alx-posts li:hover .post-item-title a,
.comment-tabs li.active a,
.comment-awaiting-moderation,
.child-menu a:hover,
.child-menu .current_page_item > a,
.wp-pagenavi a { color: #213f99; }

.themeform input[type="submit"],
.themeform button[type="submit"],
.s1 .sidebar-top,
.s1 .sidebar-toggle,
#flexslider-featured .flex-control-nav li a.flex-active,
.post-tags a:hover,
.s1 .widget_calendar caption,
#footer .widget_calendar caption,
.author-bio .bio-avatar:after,
.commentlist li.bypostauthor > .comment-body:after,
.commentlist li.comment-author-admin > .comment-body:after { background-color: #213f99; }

.post-format .format-container { border-color: #213f99; }

.s1 .alx-tabs-nav li.active a,
#footer .alx-tabs-nav li.active a,
.comment-tabs li.active a,
.wp-pagenavi a:hover,
.wp-pagenavi a:active,
.wp-pagenavi span.current { border-bottom-color: #213f99!important; }
        

.s2 .post-nav li a:hover i,
.s2 .widget_rss ul li a,
.s2 .widget_calendar a,
.s2 .alx-tab .tab-item-category a,
.s2 .alx-posts .post-item-category a,
.s2 .alx-tab li:hover .tab-item-title a,
.s2 .alx-tab li:hover .tab-item-comment a,
.s2 .alx-posts li:hover .post-item-title a { color: #ffcc02; }

.s2 .sidebar-top,
.s2 .sidebar-toggle,
.post-comments,
.jp-play-bar,
.jp-volume-bar-value,
.s2 .widget_calendar caption { background-color: #ffcc02; }

.s2 .alx-tabs-nav li.active a { border-bottom-color: #ffcc02; }
.post-comments span:before { border-right-color: #ffcc02; }
        

#nav-header.nav-container { background-color: #33363b; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #33363b; }
}
        
body { background-color: #eaeaea; }
</style>
<style id="tt-easy-google-font-styles" type="text/css">p { background-color: #ffffff; color: #0c0c0c; font-family: 'Libre Baskerville'; font-size: 14px; font-style: normal; font-weight: 400; line-height: 1.8; }
h1 { color: #0c0c0c; font-family: 'Lucida Sans Unicode'; font-style: normal; font-weight: 400; }
h2 { color: #0c0c0c; font-family: 'Lucida Sans Unicode'; font-style: normal; font-weight: 400; }
h3 { color: #0c0c0c; font-family: 'Lucida Sans Unicode'; font-style: normal; font-weight: 400; }
h4 { color: #0c0c0c; font-family: 'Lucida Sans Unicode'; font-style: normal; font-weight: 400; }
h5 { font-family: 'Lucida Sans Unicode'; font-style: normal; font-weight: 400; }
h6 { color: #0c0c0c; font-family: 'Lucida Sans Unicode'; font-style: normal; font-weight: 400; }
</style></head>

<body class="single single-post postid-43953 single-format-standard col-2cl boxed topbar-enabled unknown hueman">

<div id="wrapper">

  
  <header id="header">
      <nav class="nav-container group" id="nav-topbar">
  <div class="nav-toggle"><i class="fa fa-bars"></i></div>
  <div class="nav-text"><!-- put your mobile menu text here --></div>
  <div class="nav-wrap container"><ul id="menu-main-menu" class="nav container-inner group"><li id="menu-item-36775" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36775"><a href="http://www.uafsunstar.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-42989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42989"><a href="http://www.uafsunstar.com/about/staff/">Staff</a></li>
	<li id="menu-item-38320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38320"><a href="http://www.uafsunstar.com/about/office-hours/">Office Hours</a></li>
</ul>
</li>
<li id="menu-item-36777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36777"><a href="http://www.uafsunstar.com/contribute/">Contribute</a>
<ul class="sub-menu">
	<li id="menu-item-42820" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-42820"><a href="http://www.uafsunstar.com/submit/">Submit Photos</a></li>
	<li id="menu-item-36778" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36778"><a href="http://www.uafsunstar.com/contribute/letters-to-the-editor/">Letters to the Editor</a></li>
	<li id="menu-item-36780" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36780"><a href="http://www.uafsunstar.com/contribute/pitch-a-story/">Pitch a Story</a></li>
</ul>
</li>
<li id="menu-item-36816" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-36816"><a href="http://www.uafsunstar.com/advertising/">Advertising</a>
<ul class="sub-menu">
	<li id="menu-item-37033" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37033"><a href="http://www.uafsunstar.com/advertising/">Information</a></li>
	<li id="menu-item-36817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-36817"><a href="http://www.uafsunstar.com/advertising/orders/">Place an Advertisement</a></li>
</ul>
</li>
<li id="menu-item-43110" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-43110"><a href="http://www.uafsunstar.com/classified-ads/classifieds-list/">Classifieds</a>
<ul class="sub-menu">
	<li id="menu-item-43112" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-43112"><a href="http://www.uafsunstar.com/post-a-classified/">Post a Classified</a></li>
</ul>
</li>
<li id="menu-item-36818" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36818"><a href="http://www.uafsunstar.com/category/archive/">Archive</a>
<ul class="sub-menu">
	<li id="menu-item-39194" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-39194"><a href="http://issuu.com/coldrunes">Full Issues</a></li>
	<li id="menu-item-36820" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36820"><a href="http://www.uafsunstar.com/category/archive/2011-2012/">2011-2012</a></li>
	<li id="menu-item-36821" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36821"><a href="http://www.uafsunstar.com/category/archive/2012-2013/">2012-2013</a></li>
	<li id="menu-item-43072" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43072"><a href="http://www.uafsunstar.com/category/archive/2013-2014/">2013-2014</a></li>
	<li id="menu-item-36823" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36823"><a href="http://www.uafsunstar.com/category/archive/2014-2015/">2014-2015</a></li>
	<li id="menu-item-42830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42830"><a href="http://www.uafsunstar.com/category/archive/2015-2016/">2015-2016</a></li>
</ul>
</li>
<li id="menu-item-38080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38080"><a href="http://www.uafsunstar.com/category/columns/calendar/">Calendar</a></li>
</ul></div>

  <div class="container">
    <div class="container-inner">
      <div class="toggle-search"><i class="fa fa-search"></i></div>
      <div class="search-expand">
        <div class="search-expand-inner">
          <form method="get" class="searchform themeform" action="http://www.uafsunstar.com/">
	<div>
		<input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" />
	</div>
</form>        </div>
      </div>
    </div><!--/.container-inner-->
  </div><!--/.container-->

</nav><!--/#nav-topbar-->    <div class="container group">
    <div class="container-inner">
                      <a href="http://www.uafsunstar.com/" rel="home">
            <img class="site-image" src="http://www.uafsunstar.com/wp-content/uploads/2015/08/cropped-Website-masthead-01.png" alt="The Sun Star">
          </a>
      
              <nav class="nav-container group" id="nav-header">
          <div class="nav-toggle"><i class="fa fa-bars"></i></div>
          <div class="nav-text"><!-- put your mobile menu text here --></div>
          <div class="nav-wrap container">
            <ul id="menu-main" class="nav container-inner group"><li id="menu-item-29648" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29648"><a href="http://www.uafsunstar.com/category/news/">News</a></li>
<li id="menu-item-29650" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29650"><a href="http://www.uafsunstar.com/category/arts-entertainment/">Arts</a></li>
<li id="menu-item-29647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29647"><a href="http://www.uafsunstar.com/category/features/">Features</a></li>
<li id="menu-item-29649" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29649"><a href="http://www.uafsunstar.com/category/sports/">Sports</a></li>
<li id="menu-item-29652" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29652"><a href="http://www.uafsunstar.com/category/asuaf-meetings/">ASUAF</a></li>
<li id="menu-item-29651" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29651"><a href="http://www.uafsunstar.com/category/columns/">Columns</a></li>
<li id="menu-item-43329" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43329"><a href="http://www.uafsunstar.com/category/police-blotter/">Police Blotter</a></li>
</ul>          </div>
        </nav><!--/#nav-header-->
      
    </div><!--/.container-inner-->
  </div><!--/.container-->
</header><!--/#header-->
  
  <div class="container" id="page">
    <div class="container-inner">
            <div class="main">
        <div class="main-inner group">
          
<section class="content">

	<div class="page-title pad group">
  			<ul class="meta-single group">
			<li class="category"><a href="http://www.uafsunstar.com/category/editorial-2/letters-from-the-editor/" rel="category tag">Letters from the Editor</a></li>
					</ul>

	
</div><!--/.page-title-->
	<div class="pad group">

					<article class="post-43953 post type-post status-publish format-standard hentry category-letters-from-the-editor">
				<div class="post-inner group">

          <h1 class="post-title entry-title">Letters from the Editor: Flesh and blood</h1>
<p class="post-byline">by   <span class="vcard author">
     <span class="fn"><a href="http://www.uafsunstar.com/author/spencer-tordoff-2/" title="Posts by Spencer Tordoff" rel="author">Spencer Tordoff</a></span>
   </span> &middot;
                            Published <time class="published" datetime="November 22, 2016">November 22, 2016</time>
              &middot; Updated <time class="updated" datetime="November 21, 2016">November 21, 2016</time>
               </p>
					
					<div class="clear"></div>

					<div class="entry themeform share">
						<div class="entry-inner">
							<p>Thanksgiving is not a universally positive holiday for many. Indeed, in some households it&#8217;s viewed with dread, representing an awkward, obligatory time of year where political views and family skeletons create a minefield of arguments and hurt feelings. It is nevertheless my very favorite holiday, and I find myself incredibly frustrated by the people and corporations that would rather move it aside entirely in favor of sale prices and endless replays of &#8220;Jingle Bells.&#8221;</p>
<p>Perhaps my infatuation with the feast is due to the fact that I have never really dreaded it. Once Thanksgiving was a time for family and close family friends, but upon moving to Seattle the yearly tradition became one of our merry band of expatriates, refugees from Alaska, California and the Midwest brought together by circumstance and oddity. In any case, it was a time for merriment and the gathering of loved ones. I&#8217;ll be in Seattle preparing for this year&#8217;s event by the time you pick up this newspaper and I definitely won&#8217;t be thinking of class (or work) for the duration.</p>
<p>Perhaps it&#8217;s the aspect of choice that makes Thanksgiving finally come into its own. Nobody likes being dragged by familial association into groups of unfamiliar and possibly hostile people, and the fact that the holiday does that to so many is probably why it has such a bad rap. <a target="_blank" href="https://www.youtube.com/watch?v=mdVTPOjuDSQ">They say the family of the 21st century is made up of friends, not family</a>, and whether you find blood is thicker than water or vice versa it&#8217;s probably safe to assume that you would rather be with those you choose rather than those you were born into.</p>
<p>I, for one, will be spending time with my 21st century family this holiday, and to those of you doing the same, I hope that it gives you the boost we&#8217;ll all need going into the final stretch of the fall semester. If you&#8217;re venturing forth into that dragon&#8217;s den of disagreeable family members, then I hope you keep your head down and power through. And if you have Christmas decorations up, stay the hell out of my face until Friday.</p>
<p> Happy Thanksgiving, hang in there everybody.</p>
							<nav class="pagination group">
                              </nav><!--/.pagination-->
						</div>

            <div class="sharrre-container">
	<span>Share</span>
    	   <div id="facebook" data-url="http://www.uafsunstar.com/letters-from-the-editor-flesh-and-blood/" data-text="Letters from the Editor: Flesh and blood" data-title="Like"></div>
        </div><!--/.sharrre-container-->

<script type="text/javascript">
	// Sharrre
	jQuery(function($){
    		        $('#facebook').sharrre({
    			share: {
    				facebook: true
    			},
    			template: '<a class="box" href="#"><div class="count" href="#">{total}</div><div class="share"><i class="fa fa-facebook-square"></i></div></a>',
    			enableHover: false,
    			enableTracking: true,
          buttons:{layout: 'box_count'},
    			click: function(api, options){
    				api.simulateClick();
    				api.openPopup('facebook');
    			}
    		});
                		
	});
</script>
						<div class="clear"></div>
					</div><!--/.entry-->

				</div><!--/.post-inner-->
			</article><!--/.post-->
		
		<div class="clear"></div>

		
		
		
		

<h4 class="heading">
	<i class="fa fa-hand-o-right"></i>You may also like...</h4>

<ul class="related-posts group">

		<li class="related post-hover">
		<article class="post-43285 post type-post status-publish format-standard hentry category-editorial-2 category-letters-from-the-editor">

			<div class="post-thumbnail">
				<a href="http://www.uafsunstar.com/letters-from-the-editor-survival-instinct/" title="Letters from the Editor: Survival instinct">
																								</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="http://www.uafsunstar.com/letters-from-the-editor-survival-instinct/" rel="bookmark" title="Letters from the Editor: Survival instinct">Letters from the Editor: Survival instinct</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2016-10-11 10:30:00">October 11, 2016</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="http://www.uafsunstar.com/author/spencer-tordoff-2/" title="Posts by Spencer Tordoff" rel="author">Spencer Tordoff</a></span>
    </span> &middot; Published <span class="published">October 11, 2016</span>
     &middot; Last modified <span class="updated">October 10, 2016</span>  </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-39156 post type-post status-publish format-standard has-post-thumbnail hentry category-2015-2016 category-letters-from-the-editor">

			<div class="post-thumbnail">
				<a href="http://www.uafsunstar.com/letter-from-the-editor-the-artists-curse/" title="Letter from the Editor: The Artist&#8217;s Curse">
					<img width="368" height="245" src="http://www.uafsunstar.com/wp-content/uploads/2015/09/IMG_0056.jpg" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="DANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNYDANNY" srcset="http://www.uafsunstar.com/wp-content/uploads/2015/09/IMG_0056.jpg 5472w, http://www.uafsunstar.com/wp-content/uploads/2015/09/IMG_0056-300x200.jpg 300w, http://www.uafsunstar.com/wp-content/uploads/2015/09/IMG_0056-1024x683.jpg 1024w" sizes="(max-width: 368px) 100vw, 368px" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="http://www.uafsunstar.com/letter-from-the-editor-the-artists-curse/" rel="bookmark" title="Letter from the Editor: The Artist&#8217;s Curse">Letter from the Editor: The Artist&#8217;s Curse</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2015-11-10 10:20:57">November 10, 2015</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="http://www.uafsunstar.com/author/danny-fisher/" title="Posts by Danny Fisher" rel="author">Danny Fisher</a></span>
    </span> &middot; Published <span class="published">November 10, 2015</span>
     &middot; Last modified <span class="updated">September 8, 2016</span>  </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-37140 post type-post status-publish format-standard hentry category-2015-2016 category-editorial-2 category-letters-from-the-editor">

			<div class="post-thumbnail">
				<a href="http://www.uafsunstar.com/what-the-hell-you-dont-have-to-study-journalism-to-be-a-good-journalist/" title="What the hell?  You don&#8217;t have to study journalism to be a good journalist.">
																								</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="http://www.uafsunstar.com/what-the-hell-you-dont-have-to-study-journalism-to-be-a-good-journalist/" rel="bookmark" title="What the hell?  You don&#8217;t have to study journalism to be a good journalist.">What the hell?  You don&#8217;t have to study journalism to be a good journalist.</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2015-09-08 11:04:44">September 8, 2015</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="http://www.uafsunstar.com/author/danny-fisher/" title="Posts by Danny Fisher" rel="author">Danny Fisher</a></span>
    </span> &middot; Published <span class="published">September 8, 2015</span>
     &middot; Last modified <span class="updated">September 8, 2016</span>  </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		
</ul><!--/.post-related-->


		
<section id="comments" class="themeform">

	
					<!-- comments open, no comments -->
		
	
					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/letters-from-the-editor-flesh-and-blood/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="http://www.uafsunstar.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='43953' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3647d69e59" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="28"/></p>				</form>
					</div><!-- #respond -->
		
</section><!--/#comments-->
	</div><!--/.pad-->

</section><!--/.content-->


	<div class="sidebar s1">

		<a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a>

		<div class="sidebar-content">

			  			<div class="sidebar-top group">
          <p>Follow:</p>
          <ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Facebook" href="https://www.facebook.com/thesunstar" target="_blank" style="color:#1e73be"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Tumblr" href="http://uafsunstar.tumblr.com/" target="_blank" style="color:#939393"><i class="fa fa-tumblr"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Youtube" href="https://www.youtube.com/channel/UCtSby1LJsVpSGGqo1VEB-bA" target="_blank" style="color:#dd3333"><i class="fa fa-youtube"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Twitter" href="https://twitter.com/uafsunstar" target="_blank" style="color:#6b97bf"><i class="fa fa-twitter"></i></a></li></ul>  			</div>
			
				<ul class="post-nav group">
		<li class="next"></li>
		<li class="previous"><a href="http://www.uafsunstar.com/op-ed-the-tragic-flaw-of-the-democratic-party/" rel="prev"><i class="fa fa-chevron-left"></i><strong>Previous story</strong> <span>Op-Ed: The tragic flaw of the Democratic party</span></a></li>
	</ul>

			
			<div id="calendar-12" class="widget widget_calendar"><div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar">
	<caption>November 2016</caption>
	<thead>
	<tr>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
		<th scope="col" title="Sunday">S</th>
	</tr>
	</thead>

	<tfoot>
	<tr>
		<td colspan="3" id="prev"><a href="http://www.uafsunstar.com/2016/10/">&laquo; Oct</a></td>
		<td class="pad">&nbsp;</td>
		<td colspan="3" id="next" class="pad">&nbsp;</td>
	</tr>
	</tfoot>

	<tbody>
	<tr>
		<td colspan="1" class="pad">&nbsp;</td><td><a href="http://www.uafsunstar.com/2016/11/01/" aria-label="Posts published on November 1, 2016">1</a></td><td>2</td><td><a href="http://www.uafsunstar.com/2016/11/03/" aria-label="Posts published on November 3, 2016">3</a></td><td>4</td><td>5</td><td>6</td>
	</tr>
	<tr>
		<td><a href="http://www.uafsunstar.com/2016/11/07/" aria-label="Posts published on November 7, 2016">7</a></td><td><a href="http://www.uafsunstar.com/2016/11/08/" aria-label="Posts published on November 8, 2016">8</a></td><td>9</td><td>10</td><td>11</td><td>12</td><td>13</td>
	</tr>
	<tr>
		<td><a href="http://www.uafsunstar.com/2016/11/14/" aria-label="Posts published on November 14, 2016">14</a></td><td><a href="http://www.uafsunstar.com/2016/11/15/" aria-label="Posts published on November 15, 2016">15</a></td><td>16</td><td>17</td><td><a href="http://www.uafsunstar.com/2016/11/18/" aria-label="Posts published on November 18, 2016">18</a></td><td>19</td><td>20</td>
	</tr>
	<tr>
		<td><a href="http://www.uafsunstar.com/2016/11/21/" aria-label="Posts published on November 21, 2016">21</a></td><td id="today"><a href="http://www.uafsunstar.com/2016/11/22/" aria-label="Posts published on November 22, 2016">22</a></td><td>23</td><td>24</td><td>25</td><td>26</td><td>27</td>
	</tr>
	<tr>
		<td>28</td><td>29</td><td>30</td>
		<td class="pad" colspan="4">&nbsp;</td>
	</tr>
	</tbody>
	</table></div></div><div class='adkingprobanner  banner43907'><a href='http://www.fdifairbanks. com/fdiapartments/fdiapartments.htm' target="_blank" data-id='43907'><img src='http://www.uafsunstar.com/wp-content/uploads/2016/10/Wedgewood-Fountainhead-Hotels-248X900.jpg' alt='' /></a></div><script type='text/javascript'>ga('send', 'event', '', 'Impression', '');</script>
		</div><!--/.sidebar-content-->

	</div><!--/.sidebar-->

	

        </div><!--/.main-inner-->
      </div><!--/.main-->
    </div><!--/.container-inner-->
  </div><!--/.container-->
    <footer id="footer">

                  <section class="container" id="footer-full-width-widget">
          <div class="container-inner">
            		<div id="recent-posts-3" class="widget widget_recent_entries">		<h3 class="widget-title">Recent News</h3>		<ul>
					<li>
				<a href="http://www.uafsunstar.com/letters-from-the-editor-flesh-and-blood/">Letters from the Editor: Flesh and blood</a>
						</li>
					<li>
				<a href="http://www.uafsunstar.com/op-ed-the-tragic-flaw-of-the-democratic-party/">Op-Ed: The tragic flaw of the Democratic party</a>
						</li>
					<li>
				<a href="http://www.uafsunstar.com/sustainable-village-looks-to-expand/">Sustainable Village looks to expand</a>
						</li>
					<li>
				<a href="http://www.uafsunstar.com/neuroscientist-pitches-new-vision-for-ua-budget/">Neuroscientist pitches &#8216;New Vision&#8217; for UA budget</a>
						</li>
					<li>
				<a href="http://www.uafsunstar.com/gfoty-the-magic-valley-tarot-society-withchips/">GFOTY, The Magic Valley Tarot Society, withchips</a>
						</li>
					<li>
				<a href="http://www.uafsunstar.com/asuaf-recap-nov-20-senators-endorse-mace-in-dorms/">ASUAF Recap, Nov 20: Senators endorse mace in dorms</a>
						</li>
					<li>
				<a href="http://www.uafsunstar.com/photography-students-shine-in-state-shows/">Photography students shine in state shows</a>
						</li>
					<li>
				<a href="http://www.uafsunstar.com/indigenous-and-visible-fashion-with-native-perspective/">Indigenous and Visible: Fashion with Native perspective</a>
						</li>
					<li>
				<a href="http://www.uafsunstar.com/visiting-artist-explores-arctic-connections/">Visiting artist explores Arctic connections</a>
						</li>
					<li>
				<a href="http://www.uafsunstar.com/nook-on-the-street-nov-22/">&#8216;Nook on the Street Nov. 22</a>
						</li>
				</ul>
		</div>		          </div><!--/.container-inner-->
        </section><!--/.container-->
          
    
    
    <section class="container" id="footer-bottom">
      <div class="container-inner">

        <a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a>

        <div class="pad group">

          <div class="grid one-half">
                        
            <div id="copyright">
                              <p>The Sun Star &copy; 2016. All Rights Reserved.</p>
                          </div><!--/#copyright-->

            
          </div>

          <div class="grid one-half last">
            <ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Facebook" href="https://www.facebook.com/thesunstar" target="_blank" style="color:#1e73be"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Tumblr" href="http://uafsunstar.tumblr.com/" target="_blank" style="color:#939393"><i class="fa fa-tumblr"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Youtube" href="https://www.youtube.com/channel/UCtSby1LJsVpSGGqo1VEB-bA" target="_blank" style="color:#dd3333"><i class="fa fa-youtube"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Twitter" href="https://twitter.com/uafsunstar" target="_blank" style="color:#6b97bf"><i class="fa fa-twitter"></i></a></li></ul>          </div>

        </div><!--/.pad-->

      </div><!--/.container-inner-->
    </section><!--/.container-->

  </footer><!--/#footer-->

</div><!--/#wrapper-->

<script type='text/javascript' src='http://www.uafsunstar.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='http://www.uafsunstar.com/wp-content/plugins/hueman-addons/assets/front/js/jQuerySharrre.min.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201647'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var JQLBSettings = {"fitToScreen":"1","resizeSpeed":"400","displayDownloadLink":"0","navbarOnTop":"0","loopImages":"","resizeCenter":"","marginSize":"0","linkTarget":"","help":"","prevLinkTitle":"previous image","nextLinkTitle":"next image","prevLinkText":"\u00ab Previous","nextLinkText":"Next \u00bb","closeTitle":"close image gallery","image":"Image ","of":" of ","download":"Download","jqlb_overlay_opacity":"80","jqlb_overlay_color":"#000000","jqlb_overlay_close":"1","jqlb_border_width":"10","jqlb_border_color":"#ffffff","jqlb_border_radius":"0","jqlb_image_info_background_transparency":"100","jqlb_image_info_bg_color":"#ffffff","jqlb_image_info_text_color":"#000000","jqlb_image_info_text_fontsize":"10","jqlb_show_text_for_image":"1","jqlb_next_image_title":"next image","jqlb_previous_image_title":"previous image","jqlb_next_button_image":"http:\/\/www.uafsunstar.com\/wp-content\/plugins\/wp-lightbox-2\/styles\/images\/next.gif","jqlb_previous_button_image":"http:\/\/www.uafsunstar.com\/wp-content\/plugins\/wp-lightbox-2\/styles\/images\/prev.gif","jqlb_maximum_width":"","jqlb_maximum_height":"","jqlb_show_close_button":"1","jqlb_close_image_title":"close image gallery","jqlb_close_image_max_heght":"22","jqlb_image_for_close_lightbox":"http:\/\/www.uafsunstar.com\/wp-content\/plugins\/wp-lightbox-2\/styles\/images\/closelabel.gif","jqlb_keyboard_navigation":"1","jqlb_popup_size_fix":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.uafsunstar.com/wp-content/plugins/wp-lightbox-2/wp-lightbox-2.min.js?ver=1.3.4.1'></script>
<script type='text/javascript' src='http://www.uafsunstar.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":null,"extLinksTargetExt":null,"extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":null,"imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","vivusSvgSpeed":"300","isDevMode":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.uafsunstar.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?ver=3.2.10'></script>
<script type='text/javascript' src='http://www.uafsunstar.com/wp-includes/js/wp-embed.min.js?ver=4.6.1'></script>
<!--[if lt IE 9]>
<script src="http://www.uafsunstar.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script>
<![endif]-->
<script type='text/javascript' src='http://stats.wp.com/e-201647.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.3.2',blog:'20668653',post:'43953',tz:'-9',srv:'www.uafsunstar.com'} ]);
	_stq.push([ 'clickTrackerInit', '20668653', '43953' ]);
</script>
</body>
</html>
